Diablo iii launcher stuck on updating setup files singled out dating

16-Mar-2017 01:36

Net Patch 1.5.2.8180 # Diablo 3 Patch 2.4.3 (64-bit Client) # NVidia Ge Force GTX 960/PCIe/SSE2 # AMD FX(tm)-6300 Six-Core Processor × 6 # [Some Guy42] (2016-11-22) # Wine 1.7.15 = 1.7.15 (Dark Nekros) # [Super Plumus] (2013-06-08 17-14) # gettext clean [ "$PLAYONLINUX" = "" ] && exit 0 source "$PLAYONLINUX/lib/sources" TITLE="Diablo III_2" WORKING_WINE_VERSION="2.11-staging" EDITOR="Blizzard Entertainment Inc." EDITOR_URL=" PREFIX="Diablo III_32_2" AUTHOR="Some Guy42, Ravon TUS, and the POL Community" POL_Get Setup Images " " "$TITLE" POL_Setup Window_Init POL_Setup Window_Set ID 1195 POL_Debug_Init POL_Debug_Message "Starting Install -----------------------------" POL_Setup Window_presentation "$TITLE" "$EDITOR" "$EDITOR_URL" "$AUTHOR" "$PREFIX" POL_System_Set Arch "x86" POL_System_Tmp Create "$PREFIX" POL_Setup Window_message "$(eval_gettext 'NOTICE: This will install the Blizzard application first and configure the settings for Diablo 3.')" POL_Debug_Message "Downloading Install File -------------" cd "$POL_System_Tmp Dir" # now has a universal installer with language selection at start POL_Download "https:// Installer For Game?

diablo iii launcher stuck on updating setup files-43diablo iii launcher stuck on updating setup files-88

There's a bug that the new necro pack brings up and you can't see the Play button in the Blizzard App.

os=win&version=LIVE&game Program=BATTLENET_APP/Battle.net-Setup.exe" Setup Is="$POL_System_Tmp Dir/Battle.net-Setup.exe" # Removed the DVD option as it has a really old installer and game files and isn't worth using IMHO POL_Debug_Message "Creating Wine Install ------------------------" POL_Wine_Select Prefix "$PREFIX" POL_Wine_Prefix Create "$WORKING_WINE_VERSION" POL_Debug_Message "Setting Wine Variables -----------------------" Set_OS "winxp" # Updated Overrides, many of wine's dlls are up to spec now and diablo has even removed some of their own.

POL_Wine_Override DLL "native,builtin" "vcruntime140" POL_Wine_Override DLL "native,builtin" "msvcp140" POL_Wine_Override DLL "native,builtin" "ucrtbase" # Updated dependancies, Most no longer needed due to wine 2.0 (07-APR-2017) POL_Call POL_Install_corefonts POL_Call POL_Install_Physx #POL_Call POL_Install_ie8 #IE8 for future alternative Blizzard App display fix (28-JUN-2017) POL_Debug_Message "Running Install File -------------------------" POL_Wine_Wait Before "$TITLE" POL_Wine "$Setup Is" POL_Setup Window_VMS "1024" POL_System_Tmp Delete POL_Debug_Message "Creating Shortcut ----------------------------" POL_Shortcut "Launcher.exe" "$TITLE" "" "" "Game" POL_Debug_Message "Install Completed ----------------------------" POL_Setup Window_message "$(eval_gettext 'Blizzard application Installation Complete!

POL_Wine_Override DLL "native,builtin" "vcruntime140" POL_Wine_Override DLL "native,builtin" "msvcp140" POL_Wine_Override DLL "native,builtin" "ucrtbase" # Updated dependancies, Most no longer needed due to wine 2.0 (07-APR-2017) POL_Call POL_Install_corefonts POL_Call POL_Install_Physx POL_Debug_Message "Running Install File -------------------------" POL_Wine_Wait Before "$TITLE" POL_Wine "$Setup Is" -while [ !

-e "$WINEPREFIX/drive_c/$PROGRAMFILES/Diablo III/Diablo III Launcher.exe" ]; do - sleep 10 -done - -POL_Shortcut "Diablo III Launcher.exe" "$TITLE" -POL_Shortcut_Insert Before Wine "$TITLE" '#taskset -pc 0 $$' -[ "$AMD64_COMPATIBLE" == "True" ] && POL_Shortcut_Insert Before Wine "$TITLE" 'BEFORE_WINE="setarch i386 -3 -L -B -R"' - -if [ "$INSTALL_METHOD" = "DVD" ]; then - POL_Call POL_Sudo_Rehide Cdrom -fi - POL_Setup Window_VMS "1024" - -POL_Setup Window_message "$(eval_gettext '$TITLE has been installed.\n\n A special thank to Erich Hoover for his wine patch (Accept Ex Fix)')\n\n$(eval_gettext 'If you have Error 3007 on connecting, open a terminal and type:\necho 0|sudo tee /proc/sys/kernel/yama/ptrace_scope')" - POL_System_Tmp Delete POL_Debug_Message "Creating Shortcut ----------------------------" POL_Shortcut "Launcher.exe" "$TITLE" "" "" "Game" POL_Debug_Message "Install Completed ----------------------------" POL_Setup Window_message "$(eval_gettext 'Blizzard application Installation Complete')\n\n$(eval_gettext 'IMPORTANT: Login to the Blizzard app by using the email and password entries near the bottom of the login window, not the nice looking ones near the top.

There's a bug that the new necro pack brings up and you can't see the Play button in the Blizzard App.

os=win&version=LIVE&game Program=BATTLENET_APP/Battle.net-Setup.exe" Setup Is="$POL_System_Tmp Dir/Battle.net-Setup.exe" # Removed the DVD option as it has a really old installer and game files and isn't worth using IMHO POL_Debug_Message "Creating Wine Install ------------------------" POL_Wine_Select Prefix "$PREFIX" POL_Wine_Prefix Create "$WORKING_WINE_VERSION" POL_Debug_Message "Setting Wine Variables -----------------------" Set_OS "winxp" # Updated Overrides, many of wine's dlls are up to spec now and diablo has even removed some of their own.

POL_Wine_Override DLL "native,builtin" "vcruntime140" POL_Wine_Override DLL "native,builtin" "msvcp140" POL_Wine_Override DLL "native,builtin" "ucrtbase" # Updated dependancies, Most no longer needed due to wine 2.0 (07-APR-2017) POL_Call POL_Install_corefonts POL_Call POL_Install_Physx #POL_Call POL_Install_ie8 #IE8 for future alternative Blizzard App display fix (28-JUN-2017) POL_Debug_Message "Running Install File -------------------------" POL_Wine_Wait Before "$TITLE" POL_Wine "$Setup Is" POL_Setup Window_VMS "1024" POL_System_Tmp Delete POL_Debug_Message "Creating Shortcut ----------------------------" POL_Shortcut "Launcher.exe" "$TITLE" "" "" "Game" POL_Debug_Message "Install Completed ----------------------------" POL_Setup Window_message "$(eval_gettext 'Blizzard application Installation Complete!

POL_Wine_Override DLL "native,builtin" "vcruntime140" POL_Wine_Override DLL "native,builtin" "msvcp140" POL_Wine_Override DLL "native,builtin" "ucrtbase" # Updated dependancies, Most no longer needed due to wine 2.0 (07-APR-2017) POL_Call POL_Install_corefonts POL_Call POL_Install_Physx POL_Debug_Message "Running Install File -------------------------" POL_Wine_Wait Before "$TITLE" POL_Wine "$Setup Is" -while [ !

-e "$WINEPREFIX/drive_c/$PROGRAMFILES/Diablo III/Diablo III Launcher.exe" ]; do - sleep 10 -done - -POL_Shortcut "Diablo III Launcher.exe" "$TITLE" -POL_Shortcut_Insert Before Wine "$TITLE" '#taskset -pc 0 $$' -[ "$AMD64_COMPATIBLE" == "True" ] && POL_Shortcut_Insert Before Wine "$TITLE" 'BEFORE_WINE="setarch i386 -3 -L -B -R"' - -if [ "$INSTALL_METHOD" = "DVD" ]; then - POL_Call POL_Sudo_Rehide Cdrom -fi - POL_Setup Window_VMS "1024" - -POL_Setup Window_message "$(eval_gettext '$TITLE has been installed.\n\n A special thank to Erich Hoover for his wine patch (Accept Ex Fix)')\n\n$(eval_gettext 'If you have Error 3007 on connecting, open a terminal and type:\necho 0|sudo tee /proc/sys/kernel/yama/ptrace_scope')" - POL_System_Tmp Delete POL_Debug_Message "Creating Shortcut ----------------------------" POL_Shortcut "Launcher.exe" "$TITLE" "" "" "Game" POL_Debug_Message "Install Completed ----------------------------" POL_Setup Window_message "$(eval_gettext 'Blizzard application Installation Complete')\n\n$(eval_gettext 'IMPORTANT: Login to the Blizzard app by using the email and password entries near the bottom of the login window, not the nice looking ones near the top.

Net Patch 1.5.2.8180 # Diablo 3 Patch 2.4.3 (64-bit Client) # NVidia Ge Force GTX 960/PCIe/SSE2 # AMD FX(tm)-6300 Six-Core Processor × 6 # [Some Guy42] (2016-11-22) # Wine 1.7.15 = 1.7.15 (Dark Nekros) - # [Super Plumus] (2013-06-08 17-14) # gettext clean [ "$PLAYONLINUX" = "" ] && exit 0 source "$PLAYONLINUX/lib/sources" - TITLE="Diablo III" -WORKING_WINE_VERSION="1.7.15" -EDITOR="Blizzard" WORKING_WINE_VERSION="2.5-staging" EDITOR="Blizzard Entertainment Inc." EDITOR_URL=" -PREFIX="Diablo III" - PREFIX="Diablo III_32" AUTHOR="Ravon TUS, Some Guy42 and the POL Community" POL_Get Setup Images " " "$TITLE" POL_Setup Window_Init POL_Setup Window_Set ID 1195 POL_Debug_Init - -POL_Setup Window_presentation "$TITLE" "$EDITOR" "$EDITOR_URL" "" "$PREFIX" - POL_Debug_Message "Starting Install -----------------------------" POL_Setup Window_presentation "$TITLE" "$EDITOR" "$EDITOR_URL" "$AUTHOR" "$PREFIX" POL_System_Set Arch "x86" - -if [ "$POL_SELECTED_FILE" ]; then - Setup Is="$POL_SELECTED_FILE" -else - POL_Setup Window_Install Method "LOCAL, DVD" - - if [ "$INSTALL_METHOD" = "LOCAL" ]; then - POL_Setup Window_browse "$(eval_gettext 'Please select the setup file downloaded on $EDITOR website')" "$TITLE" - Setup Is="$APP_ANSWER" - fi - if [ "$INSTALL_METHOD" = "DVD" ]; then - POL_Setup Window_cdrom - POL_Call POL_Sudo_Unhide Cdrom - POL_Setup Window_check_cdrom "Diablo III Setup.exe" - Setup Is="$CDROM/Diablo III Setup.exe" - fi -fi - #POL_System_Set Arch "amd64" POL_System_Tmp Create "$PREFIX" POL_Setup Window_message "$(eval_gettext 'NOTICE: This will install the Blizzard application first and configure the settings for Diablo 3.')\n\n$(eval_gettext 'The Blizzard app install may take longer than expected to continue to the next window, but it works in most cases.